Dynamo System Requirements

To use Dynamo, you need a computer, tablet, or mobile device with a browser and internet connection.

Browser

  • The most recent version of Mozilla Firefox.
  • The latest version of Google Chrome.
  • Internet Explorer 11.
  • Microsoft Edge.
  • Safari 6, or more recent.

Dynamo Software tests under the browsers listed above and does not guarantee that Dynamo will work on all other browsers.

Browser Settings

  • Enabled Cookies
  • Enabled JavaScript

See your browser’s Help for instructions on how to enable them.

Computer

PC or Mac, with the following:

  • Memory: 2GB or more
  • Processor: Dual core or hyper-threaded, 2GHz or more.
  • Storage Space: 300MB+ for using Outlook, Import from Excel, or Mail Merge. General use does not require memory space.

Microsoft Office

Dynamo integrates with Microsoft Office through add-ins that can be easily installed. To use the integration features, you need:

PC

  • Office 2016 or 2013 with the most recent service packs from Microsoft installed.
  • Outlook: Required for the Outlook add-in and Mail Merge.
  • Word: Required for the Mail Merge and the Word Uploader add-in.
  • Excel: Required for Mail Merge, and the Excel add-in.
  • PowerPoint: Required for the PowerPoint Uploader add-in.

Mac

  • Mac OS X 10.6 or higher.
  • Outlook 2015, or 2011 for Mac with the most recent service packs from Microsoft installed.

Adobe Reader and Acrobat

Dynamo integrates with Adobe PDFs through downloadbale add-ins. To use the integration features, you need:

PC

  • Adobe Reader or Acrobat XI or later.

Tools

Dynamo comes with a series of supporting desktop tools for importing data, integrating Dynamo with Outlook, uploading files, mail-merging correspondence, and maintaining site settings. Some tools are add-ins to Microsoft Office programs, and others are stand-alone applications.

Dynamo tools require several software programs active on your computer to run properly, install tools, or to uninstall tools.

Following is a list of programs per tool:

  • .NET Framework 4.5. Required for all tools.
  • Windows Installer, as distributed with your version of Windows. Required for all tools.
  • Windows Installer 3.1 Redistributable (v2). Required only for computers running Windows XP with Service Pack 3 (SP3)
  • Visual Studio 2010 Tools for Office Runtime (version 4.0). Required for the Outlook add-in, the uploader add-ins, and the Excel import add-ins.
  • Microsoft Data Access Components (MDAC) 2.8 SP1. Required for the Excel import add in and Import Studio.
  • .NET Framework Assistant for Firefox. Required for Mail Merge.

DynaMobile – Dynamo for Mobile Devices

Apple® Devices

  • iOS version 8.0 or higher.
  • DynaMobile for iPhone. The application is available in the iTunes App Store. Search for dynamobile.

Android® Devices

  • Android OS 2.3.4 (Gingerbread) or more recent.
  • Internet connectivity.
  • DynaMobile for Android. The application is available in the Google Play Store. Search for dynamobile.

Smartphones and Tablets (Other)

DynaMobile is accessible through a mobile friendly website. Other mobile devices, such as Blackberry® devices, and Windows® phones and tablets, can access their Dynamo information provided that their device provides:

  • Touchscreen interactivity.
  • Internet connectivity.
  • An HTML5 browser.

© 1998 - 2017 Dynamo Software, formerly known as Netage Solutions. All rights reserved. Privacy Policy | Privacy Shield Notice | Safe Harbor Policy| Site Map